Subject: Character set translation software

From: Vincent Broman <[email-masked]>
Date: 16 Apr 1997 23:28:40 -0000

-----BEGIN PGP SIGNED MESSAGE-----

I've updated the "tcs" character set translation software to understand
the WinGreek v1.9 greek font character encoding, as well as "ANSEL".
It already handled Unicode UCS-2 and UTF-8, ISO 8859-*,
cp437, and a bunch of other character sets.  It only does text files,
not word processor documents.

The unix and plan9 source code for tcs and GNU/Linux debian-i386 binaries
can be found at ftp://archimedes.nosc.mil/pub/transfer/tcs* .
The md5sums for the files are as follows.

77ac903dd4573bee54f7b3dc7ea70f5e  tcs_1-3.dsc
3d433da13274d0421dba7a376da517e1  tcs_1-3.tar.gz
23d8017f2c79d1b3f923efdfb7936916  tcs_1-3_i386.changes
ec1b0a21ea1749e161b9e1e9a9380d8a  tcs_1-3_i386.deb

The code is quite generic C, so that DOS+TurboC might also compile it.
If you want to change the ANSEL character set definition,
e.g. you find mistakes, you need Python to regenerate a table in the source.

Vincent Broman,  code D783 Bayside                       Email: [email-masked]
Naval Command Control and Ocean Surveillance Center, RDT&E Div.
San Diego, CA  92152-6222,  USA                          Phone: +1 619 553 1641
=== PGP protected mail preferred.  For public key finger [email-masked] ===

---

From: Nichael Cramer <[email-masked]>
Date: Thu, 17 Apr 1997 00:27:46 -0400 (EDT)

Vincent Broman wrote:
> the WinGreek v1.9 greek font character encoding, as well as "ANSEL".[...]

On a related topic:  I've been experimenting with a Java BetaCode/Greek 
translator Applet (using the GreekGIF "font").

If you have a Java-enabled browser, you can check it out at:

  http://www.sover.net/~nichael/javatest/BCT/index.html

Comment, etc. gratefully accepted.

Nichael Cramer
work: [email-masked]
home: [email-masked]
http://www.sover.net/~nichael/